1С 8 Как защитить определенные ячейки Excel - Форум
Основное меню
 Цены


 Торговое оборудование

Поиск


Статистика


 Дополнительная информация 


Яндекс.Метрика
· RSS 21.05.2018, 07:57
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Форум » » Иж-Софт - Форум по 1С » 1С 8 Как защитить определенные ячейки Excel (Нельзя установить свойство Locked класса Range)
1С 8 Как защитить определенные ячейки Excel
agkorepanovДата: Четверг, 11.08.2016, 11:18 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 198
Репутация: 0
Статус: Offline

        ЛистДанных.UnProtect("123");    //делаем шаблон незащищенным
   
       ВсегоКолонок = ЛистДанных.Cells(1,1).SpecialCells(11).Column;
       ВсегоСтрок = ЛистДанных.Cells(1,1).SpecialCells(11).Row;
        
        
        
        для Строка = 1 по ВсегоСтрок цикл         
            для Колонка = 1 по ВсегоКолонок цикл
                Ячейка = ЛистДанных.Cells(Строка, Колонка);
                Если  ПустаяСтрока(Ячейка.Value) Тогда
       
                    ЛистДанных.Cells(Строка, Колонка).MergeArea.Locked=Ложь;
 
                КонецЕсли;                
            КонецЦикла;           
        КонецЦикла;

Если не использовать метод MergeArea и написать просто (ЛистДанных.Cells(Строка, Колонка).Locked=Ложь) или (ЛистДанных.Cells(Строка, Колонка).Locked=0) то выходит ошибка:

}: Ошибка при установке значения атрибута контекста (Locked)
                    ЛистДанных.Cells(Строка, Колонка).Locked=Ложь;
по причине:
Произошла исключительная ситуация (Microsoft Excel): Нельзя установить свойство Locked класса Range

(по английски эта ошибка пишется так: Unable to set Locked property of Range Class error)
 
Форум » » Иж-Софт - Форум по 1С » 1С 8 Как защитить определенные ячейки Excel (Нельзя установить свойство Locked класса Range)
  • Страница 1 из 1
  • 1
Поиск: